En este artículo vimos todas las novedades que trajo HPE SimpliVity 5.0.0. Una de ellas era que se descontinúa el soporte de VMware vSphere 6.7 (de hecho, no va a ser posible desplegar nodos de HPE SimpliVity 5.0.0 con ESXi 6.7), pero que se incluía el soporte para VMware vSphere 8.

Ante estos cambios, podemos hacernos la pregunta de qué está soportado y qué no a la hora de actualizar a HPE SimpliVity 5.0.0 y/o vSphere 8. Y en esta entrada trataremos de proporcionar algo de luz acerca de este tema.

Actualizaciones simplificadas

Con HPE SimpliVity 5.0.0, el proceso de actualización se va a simplificar, reduciendo los pasos. ¿Por qué?

Cuando hablábamos acerca de actualizar a vSphere 7.x, era necesario actualizar HPE SimpliVity mínimo a la versión 4.1.0. Después de esto y realizar el commit a nivel de federación, ya era posible actualizar el vCenter Server y ESXi. Recordad que el orden era realmente importante y en este artículo os lo detallábamos más en profundidad.

Para actualizar a HPE SimpliVity 5.0.0 y vSphere 8 desde vSphere 7.x, basta con actualizar primero el vCenter Server y, posteriormente, Simplivity y ESXi conjuntamente desde el Upgrade Manager, reduciendo como decíamos los pasos necesarios.

Como vCenter 7 ya está basado en Linux y no es posible desplegarlo en Windows, no es necesaria la migración del Arbiter si acaso estuvieran en la misma máquina. También, recordemos, si venimos de vSphere 7, la federación de SimpliVity estará, mínimo, en la versión 4.1.0. Y, por último, si tuviéramos algún nodo cuya actualización a HPE SimpliVity 5.0.0 no fuera posible, no hay que proceder con la actualización del vCenter Server a la versión 8.0.2.

Si nuestro entorno estuviera en la versión 6.7 de VMware vSphere y quisiéramos actualizar a la versión 8, se debería actualizar primeramente el vCenter y, después, ya se podrían actualizar conjuntamente tanto SimpliVity a la versión 5.0.0 y ESXi a la 8.

Recordemos que, para que esto fuera posible, HPE SimpliVity debería estar mínimo en la versión 4.1.0 y hay que tener cuidado con el vCenter, pues podría estar en una máquina Windows y habría que migrarla. Lo mismo pasa con el Arbiter, por si necesitamos migrar el servicio.

Si la federación estuviera en alguna versión anterior de la 4.1.0, lo primero que deberíamos hacer sería actualizar a esta versión 4.1.0 de SimpliVity o superior, teniendo en cuenta siempre la guía de interoperabilidad.

Actualizaciones soportadas: VMware vCenter 7.0.3 y ESXi 7.0.3

Como hemos comentado antes, la actualización de HPE SimpliVity a la versión 5.0.0 de software junto con la actualización a la versión 8 de vSphere va a ser ya posible desde esta nueva versión.

Si, por el motivo que sea, con nuestro vCenter Server 8, decidiéramos actualizar los ESXi de sólo uno de los clusters a la versión 8 también (actualizando la federación de Simplivity a la 5.0.0), también sería posible puesto que HPE SimpliVity admite clusters mixtos.

Y, por supuesto, también podríamos estar trabajando con ambos clusters utilizando la versión 7.x de ESXi (con vCenter 8 y HPE SimpliVity 5.0.0).

Actualizaciones soportadas: desde VMware vCenter 6.7

VMware permite la actualización directa desde ESXi 6.7U3 a ESXi 8.0.2. Por tanto, si quisiéramos actualizar la federación de HPE SimpliVity a la versión 5.0.0 junto a la versión 8 de vSphere desde otra versión anterior de SimpliVity y la 6.7 de ESXi, sería perfectamente posible.

Actualizaciones no soportadas: HPE SimpliVity 4.2.0

Hemos hablado de las actualizaciones hacia la versión 5.0.0 de HPE SimpliVity. Pero ¿qué pasa cuando estamos trabajando con la versión 4.2.0 de HPE SimpliVity en alguno de nuestros clusters?

En primer lugar, no se recomienda tener en la federación de HPE SimpliVity clusters por debajo de la versión 5.0.0 cuando el vCenter Server se ha actualizado a la versión 8.

Y, por otro lado, ESXi 8.0.2 no es compatible con HPE SimpliVity 4.2.0. Por tanto, el Upgrade Manager bloqueará esa actualización.

En definitiva, tenemos que asociar ESXi 8 a HPE SimpliVity 5.0.0. Con una versión anterior de SimpliVity, esa actualización a ESXi 8 no va a ser posible.

Actualizaciones no soportadas: Gen9

Tampoco va a ser posible actualizar a VMware vSphere 8 con servidores Gen9. Por tanto, conviene no intentar actualizar el vCenter Server a la versión 8 en esas federaciones con clusters de servidores Gen9.


Como vemos, teniéndolo claro, el proceso de actualización de HPE SimpliVity junto con VMware vSphere no es complicado. No obstante, os animamos a planificar las actualizaciones de vuestros entornos SimpliVity con el HPE SimpliVity Upgrade Planner y, por supuesto, si tenéis dudas o queréis conocer algo más en detalle, os leeremos atentamente en comentarios.

Gracias por vuestra atención y ¡espero que os sea de utilidad!

Comparte este artículo

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *